UPDATE: solved reinstall Windows Store app, if it has been removed during post OOBE

UPDATE, 14.09.2020:

I’ve got lot’s of comment to this blog post where people have still some issues to deploy AppX’s. So I would like to extend this post here with my script how I solved it on the customer site.

We have to care of two things:

  • this script has to execute in the user session,
  • it has to run when the .flg mark file (%LOCALAPPDATA%\ClientLog\Appx_Installflag_%VAR_AlarmsVersion%.flg) doesn’t exist.

################################################

I had previosly an interesting use case at the customer, I had to reinstall a built-in application on a Windwos 10 client :

  • Windows Store app has been removed in the post OOBE phase when W10 v1709 has been installed. After the W10 v1803 upgrade process, this application won’t be installed (again) automatically.

If you remove these kind of built-in applications to “early” during the OS installation phase or even during the upgrade, it’s not so easy to reinstall again.

Microsoft comments especially this Windows Store use case so:
The Store app can’t be removed. If you want to remove and reinstall the Store app, you can only bring Store back by either restoring your system from a backup or resetting your system. Instead of removing the Store app, you should use group policies to hide or disable it.
I read lot’s of articles about solutions and workarounds like:

  • Just run the following PowerShell commands:
    Add-AppxPackage -DisableDevelopmentMode -Register “C:\Program Files\WindowsApps\Microsoft.WindowsStore_11606.1001.39.0_x64__8wekyb3d8bbwe\AppXManifest.xml”
    Add-AppxPackage -DisableDevelopmentMode -Register “C:\Program Files\WindowsApps\Microsoft.WindowsStore_11606.1001.394.0_neutral_~_8wekyb3d8bbwe\AppxMetadata\AppxBundleManifest.xml”
  • If you wish to reinstall Windows 10 Store, you can also open an elevated PowerShell windows, type the following command and hit Enter:
    Get-AppXPackage *WindowsStore* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

These commands could work for sure, if ‘only’ as AppXPackage will be removed. But if these apps will never be provisioned, it won’t work, like in my case.

That’s why I had to find another solution: Microsoft has an ISO on VLSC (search for “Windows 10 Inbox Apps“) containing all of the pre-installed apps. Download this ISO and use these source files.

IMPORTANT: be careful, these ISO are depending on your Windows 10 versions. Download and use the correct one.

The ISO also contains the ‘NET.Native‘ and ‘VCLibs‘ appx files, they should be required for the Windows Store installation.

My one-line PS script to reinstall the Windows Store app looks very simple:

Note that the this command can reinstall not just the Store app but also all other default apps that ship with Windows 10 which have been removed for some reason.

Just let me know in comments, if is works for you too…

Happy reinstalling respectively re-engineering 🙂

42 Comments


  1. Thanks so much, this saved my bacon!!

    Reply

  2. Do you know the commands in powershell to reinstall the NET.Native and VCLibs appx files?

    We have problems after the sysprep to install them and other native apps.

    Reply

    1. This ISO contains these required files too. You can just use the same one-line script for the installation as well.

      Reply

  3. Hi,

    We succesfully restored the Mail and Calender app by your guide.

    Great article!

    Thank you!

    Reply

      1. One last question, we have W10 1803 x64 and we now used the Microsoft.WindowsCommunicationsApps_8wekyb3d8bbwe.appxbundle
        Microsoft.WindowsCommunicationsApps_8wekyb3d8bbwe.xml
        from the x86fre folder. What is the difference with the same files from the amd64fre folder on the Inbox ISO? Just to make sure we use the right files.

        Reply

        1. It’s just like for other application scenarios:
          – which one are you supporting,
          – which one are fitting to your operating system,
          – do you have other dependency packages/applications?
          I would definitely recommend to use amd64/arm64 for your W10 x64 architecture. But for sure it’s working with x86 apps too.

          Reply

  4. You’re a lifesaver!

    Excellent guide!

    Reply

  5. You can’t use the same line for NET.Native and VCLibs because there is no corresponding license file… unless it doesn’t need it?

    Reply

    1. For these Appx’s (Microsoft.NET.Native.Runtime* and Microsoft.VCLibs*) you don’t need the licensepath parameter. Either use -SkipLicense!

      Reply

  6. thanks for this, we accidentally uninstalled it 🙂

    Reply

  7. I am getting “Add-AppxProvisionedPackage : Element not found.” when I run the command

    any idea what could be the issue ?

    Reply

    1. Maybe, because that is not the version that applies to your W10 build.

      Reply

      1. I’m having this same issue. I’ve double checked the version, 1803 for both so that doesn’t appear to be the cause. I’ve tried multiple packages on the possibility there was something peculiar about Calculator, but everything seems to do the same.

        Reply

        1. For Calculator, Alarms or StickyNotes, you could simply redeploy the AppX:
          Get-AppxPackage -allusers *windowscalculator* | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

          Reply

  8. I have seen this mentioned elsewhere, but nobody ever said where to get the ISO from. Thank you so much for that! Also, your one-liner is better than their 4 lines of code!

    Reply

  9. Thanks for this tip, I was able to restore Microsoft Photos on my master image!

    Reply

  10. Getting Element not Found error attemting to reinstall Skype App.
    Using command Add-AppxProvisionedPackage -Online -PackagePath “G:\amd64fre\Microsoft.SkypeApp_kzf8qxf38zg5c.appxbundle” –LicensePath “G:\and64fre\Microsoft.SkypeApp_kzf8qxf38zg5c.xml”
    Version are correct

    I can reinstall Skype app for logged in users using command get-appxpackage -AllUsers Microsoft.SkypeApp | foreach { Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml” }
    But is not provisioned for new users logging in

    Thanks

    George

    Reply

    1. why you even tried to install provisionedpackage if you already had that app in your machine?

      Reply

  11. Thank you!!! Thank you!!! Thank you!!! Searched for HOURS and finally stumbled upon your recommendation and it worked like a champ!

    Reply

  12. How i download Windows 10 Inbox Apps without VLSC?

    Reply

  13. Absolutely brilliant. Well explained and easy to follow, perfect results in restoring the entire Store and other apps! Thank you for sharing your knowledge. Cheers!

    Reply

  14. Hi I don’t have VLSC, is there another way to get the iso? Or maybe use the “normal” iso?

    Reply

    1. Actually, you have to get this “special” ISO for inbox apps which is only available via VLSC portal.
      Take care, as I mentioned in the blog, this file is depending on your W10 build.

      Reply

  15. I don’t have access to VLSC, is there a way to get this iso? Formatting the computer sounds like overkill to me, I refuse to do that just for getting the Store back.

    Reply

  16. I’ve an windows 10 v1909 image without microsoft store on several machines. A Windows 10 Inbox Package for v1909 isn’t availible in VLSC.

    Do oyu have any hint? :-/

    Thank you very much and btw great post 😉

    Reply

    1. Hi Jens, you can simply try to use the ISO file from the 1903 image:
      SW_DVD9_NTRL_Win_10_1903_32_64_ARM64_MultiLang_App_Update_X22-01657.ISO

      You can install a new computer from scratch and check the Windows Store version. If you have the same version on the ISO, you won. 😉

      Reply

  17. We had a third party image our devices and had removed store (unknown to us) – thankfully your solution worked now we can use our Business Store. Thanks very much for this!

    Reply

  18. Great information, have been looking to get a few apps back into an image. One question, the Add-AppxProvisionedPackage does not seem to install the app on other user accounts, is there a way to have it install for all users?

    Reply

    1. I see here following options:
      – You can use the command Add-AppxProvisionedPackage cmdlet with the -Online switch
      – Use DISM command: DISM.EXE /Online /add-ProvisionedAppxPackages
      – You can create a run once task which will be executed after each user logon.
      – Or a “back-to-the-roots” solution could be a simple scheduled ask with a login trigger.

      Reply

  19. Can anyone tell me I were to get a few Enterprise licenses, so that I can get access to the Windows 10 Inbox Apps, would I be able to download the Windows 10 Inbox Apps for my non-enterprise versions of Windows 10 which is 1909? Thanks

    Reply

    1. You can use the same appbundle’s for other versions too.

      Reply

      1. I tried this on our Virtual Master W10 Image. It worked and the two packages I wanted came back and both loaded without issue. However, I then rolled this image out to the users and none of them see these two apps on their start menu like I do on the master image. I have tried the -allusers switches etc. Can anyone suggest anything not already mentioned?

        Reply

        1. ‘kill -n explorer’ already tried?

          Reply

          1. No, I haven’t tried this. What would this achieve?


          2. Yes, it didnt make any difference. I’ve re-installed Sticky Notes, Photo Viewer and Snip and Sketch. They all appear under Start in the list and all open perfectly ok as the local administrator account on the Master Image. Once I roll this image out to create desktops for users, these desktops do not have these icons anywhere. I have tried all the commands with -allusers etc but they dont appear.


          3. Check the latest blog update (script). Hope it helps you.


  20. I tried this on our Virtual Master W10 Image. It worked and the two packages I wanted came back and both loaded without issue. However, I then rolled this image out to the users and none of them see these two apps on their start menu like I do on the master image. I have tried the -allusers switches etc. Can anyone suggest anything not already mentioned?

    Reply

Leave a Reply to reg Cancel reply

Your email address will not be published. Required fields are marked *